Inserting notes

Inserting notes

The simplest way to enter a note in the matrix view is to use the mouse. To do this, select the pencil tool on the toolbar, and then click and drag on the matrix editor. The note will be entered at the time and pitch corresponding to the point you click at, and will have a duration corresponding to the distance you drag before releasing the mouse button.

You can also draw notes using the Select tool (the arrow), by clicking and dragging either with the middle mouse button, or with the left mouse button and Ctrl pressed.

By default, the time and duration are snapped to a particular grid unit, according to the Grid setting on the View menu or the toolbar. You can prevent this effect by holding down Shift while clicking and dragging.

Typing notes with the PC keyboard


The durations of notes entered from the keyboard are controlled by the Grid setting on the View menu or toolbar. You can set this using the number keys:

  • 5 – Whole bar

  • 1 – Beat

  • 2 – Half note (minim)

  • 4 – Quarter note (crotchet)

  • 8 – Eighth note (quaver)

  • 6 – Sixteenth note (semiquaver)

  • 3 – Thirty-second note (demisemiquaver)

  • 0 – Sixty-fourth note (hemidemisemiquaver)


Once the correct duration is selected in the Grid menu, you can insert a note at the current position of the insert cursor by pressing one of the pitch keys:

  • A – Do (the tonic of the current key in the current clef)

  • S – Re

  • D – Mi

  • F – Fa

  • J – So

  • K – La

  • L – Ti

Holding Shift while pressing a key will sharpen the note (except for Mi and Ti, which don't have sharpened versions) and holding Shift and Ctrl together will flatten it (except for Fa and Do).

To enter notes an octave higher, use the corresponding keys on the next row up: Q, W, E, R, U, I, and O. Likewise to enter notes an octave lower, use Z, X, C, V, B, N and M.

Other remarks

All of the insertion commands are also available on a submenu of the Tools menu. It's unlikely you'd ever want to navigate the menus just to insert a single note, but the menus show the keyboard shortcuts and so provide a useful reference in case you forget which key is which.

The keyboard shortcuts are currently designed for use with a QWERTY-layout keyboard. There is not yet any way to remap the keys for another layout, short of reassigning each key individually using Settings->Configure Shortcuts....

Entering notes using a MIDI keyboard

You can enter notes into the matrix editor one at a time using a MIDI keyboard or other MIDI control device. The matrix editor uses the pitches you play on the keyboard, but the durations you have selected in the Grid setting of the editor itself. This is known as "step recording".

To start entering notes from a MIDI keyboard, first make sure the keyboard is configured as a MIDI record device. Then make sure you have the right Grid setting in the View menu or toolbar, as this controls the note duration. Then press the step recording button on the matrix editor's toolbar, or select Step Recording from the Tools menu. From that point on all notes pressed on the MIDI keyboard will be inserted at the current insertion time in that window, until step recording is switched off again or activated in a different window or the window is closed.

You can change the Grid setting while step recording is in progress, in order to insert notes of different durations.