The Matrix editor

Table of Contents

The Rosegarden matrix editor enables you to view and edit music in a simple, logical format: each note represented as a block in a grid, at a height corresponding to the pitch.

Rosegarden's matrix editor

Each matrix editor window shows a single segment. To edit a segment, just right-click on it in the main canvas and select the matrix editor from Segments → Open in Matrix Editor (M). Alternatively, you can configure Rosegarden to make the matrix editor the default editor available when you double-click on a segment.

The Grid and Quantize controls

The matrix view contains Grid and Quantize menus in its main toolbar.

The Grid menu controls the size of the visible grid in the background of the matrix view, as well as the time resolution used when entering and moving notes. After you set it to a particular time value, the normal note insertion and drag operations will then snap automatically to grid points spaced at that time width. You can override the snap-to-grid effect temporarily by holding down Shift during editing, or you can disable it by setting the Grid menu to None.

The Quantize menu works rather differently. Rather than controlling the behaviour of other editing tools, it actually performs an action. When you change the value in this menu, the selected notes – or the whole segment if nothing is selected – will immediately be quantized using a grid quantizer of the chosen resolution.

The Quantize menu also shows you continuously what resolution the current segment or selection is quantized to. For example, if you select a set of notes that start on consecutive quarter-note beats, the Quantize menu will update itself to show 1/4, as this is the coarsest resolution consistent with the existing quantization of the current selection.

Inserting notes

The simplest way to enter a note in the matrix view is to use the mouse. To do this, select the pencil tool on the toolbar, and then click and drag on the matrix editor. The note will be entered at the time and pitch corresponding to the point you click at, and will have a duration corresponding to the distance you drag before releasing the mouse button.

You can also draw notes using the select tool , by clicking and dragging either with the middle mouse button, or with the left mouse button and Ctrl pressed.

By default, the time and duration are snapped to a particular grid unit, according to the Grid setting on the View menu or the toolbar. You can prevent this effect by holding down Shift while clicking and dragging.

Typing notes with the PC keyboard

Duration

The durations of notes entered from the keyboard are controlled by the Grid setting on the View → Grid menu or toolbar. You can set this using the number keys:

  • 5 – Whole bar
  • 1 – Beat
  • 2 – Half note (minim)
  • 4 – Quarter note (crotchet)
  • 8 – Eighth note (quaver)
  • 6 – Sixteenth note (semiquaver)
  • 3 – Thirty-second note (demisemiquaver)
  • 0 – Sixty-fourth note (hemidemisemiquaver)

Pitch

Once the correct duration is selected in the Grid menu, you can insert a note at the current position of the insert cursor by pressing one of the pitch keys:

  • A – Do (the tonic of the current key in the current clef)
  • S – Re
  • D – Mi
  • F – Fa
  • J – So
  • K – La
  • L – Ti

Holding Shift while pressing a key will sharpen the note (except for Mi and Ti, which don't have sharpened versions) and holding Shift+Ctrl together will flatten it (except for Fa and Do).

To enter notes an octave higher, use the corresponding keys on the next row up: Q, W, E, R, U, I, and O. Likewise to enter notes an octave lower, use Z, X, C, V, B, N and M.

Other remarks

All of the insertion commands are also available on a submenu of the Tools menu. It's unlikely you'd ever want to navigate the menus just to insert a single note, but the menus show the keyboard shortcuts and so provide a useful reference in case you forget which key is which.

The keyboard shortcuts are currently designed for use with a QWERTY-layout keyboard. There is not yet any way to remap the keys for another layout, short of reassigning each key individually using Settings → Configure Shortcuts…. FIXME confirm this is not available in QT4 Rosegarden SOM

Entering notes using a MIDI keyboard

You can enter notes into the matrix editor one at a time using a MIDI keyboard or other MIDI control device. The matrix editor uses the pitches you play on the keyboard, but the durations you have selected in the Grid setting of the editor itself. This is known as “step recording”.

To start entering notes from a MIDI keyboard, first make sure the keyboard is configured as a MIDI record device. Then make sure you have the right grid setting in the View menu or toolbar, as this controls the note duration. Then press the step recording button on the matrix editor's toolbar, or select Tools → Step Recording. From that point on all notes pressed on the MIDI keyboard will be inserted at the current insertion time in that window, until step recording is switched off again, or activated in a different window, or the window is closed.

You can change the grid setting while step recording is in progress, in order to insert notes of different durations.

Selecting notes

To select notes in the matrix editor, switch to the select F2 tool and then outline a rectangular area containing the notes you want to select. The selected events will then be highlighted in blue. If you instead click on a single event, just that event will be selected.

If you hold Shift while dragging out a rectangle or clicking on a note, the new selection will be added to any existing selection instead of replacing it.

To clear a selection, click in an empty space on the matrix editor, or hit the Escape key.

You can also select all of the notes of a given pitch, by shift-clicking on a key in the piano keyboard down the left side of the matrix editor. You can also shift-click and drag to select a range of pitches. This selection is added to any existing selection you have, so if you want a clean new selection, clear the old one first.

Filtering the selection

Edit → Filter Selection offers you the ability to filter a range of events in any of several categories out of your selection. You can use this to refine the selection, if you want some action to apply to only certain events in it.

The event filter dialog

All ranges may be either inclusive or exclusive.

An inclusive range will remove events on either side of it from the selection. You can use this, for example, to filter everything below middle C and above the A above middle C out of your selection.

An exclusive range will remove the events within the range itself, leaving everything on either side of it selected. Using the same search points as in the previous example, you would use an exclusive range to remove everything between middle C and the A above middle C from your selection, while leaving everything above and below that range selected.

Once your selection has been filtered, you can manipulate it by any conventional means.

Moving and copying notes

You can move notes in both time and pitch on the matrix editor by either clicking and dragging them with the move tool, or selecting them and then dragging them with the select tool.

To copy notes, select them and then use the standard copy and paste functions. After the paste the pasted notes will be selected instead, and you can then drag them wherever you need them. You may also copy notes by selecting them with the select tool, then keeping Ctrl pressed click-and-drag the selected notes in a new position.

 
 
doc/matrix-en.txt · Last modified: 2013/07/02 12:55 (external edit)
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki