譜面エディタ

概要

Rosegardenの譜面エディタは、伝統的なスコア記法で1つまたはそれ以上の五線譜を表示、編集することを可能にします。これは、セグメント→編集→譜面エディタを開く(Segments → Edit With → Open in Notation Editor) (N)にあります。

Rosegardenの譜面エディタ

Rosegardenは、まず第一に、シーケンサーアプリケーションとして、最も互換性のある譜面を提供しようとしています。これは、エディタが、和音、オーバラップかつ連桁化されたグループ、三連符と任意の連符、装飾音、強弱法、アクセント、テキストなどをサポートしますが、専用の楽譜編集ソフトが行うような、レイアウト上で細かな制御を提供しないことを意味します(特に対位法の音楽で)。印刷品質が提供出来るLiliPondへのエクスポートが出来ますが、Rosegardenは印刷品質の楽譜を生成しません。

単一または複数行の五線譜

Rosegardenメインウィンドウから作譜エディタを開くためには3つの方法があります。それらはすべて、メインウィンドウにいくつかのセグメントが存在することを最初に要求し、そのため、もしも、新しいコンポジション作り始めるならば、それを編集することを考え始める前に、セグメントを作成する必要があります。

セグメント上でのダブルクリック

最も明瞭な手段は、メインキャンバス中でセグメントをダブルクリックする方法です。これは既定のエディタ(譜面、マトリクスまたはイベントリスト)として設定したもののどれかで、セグメントをオープンします。既定値は譜面エディタです。そのため、1つのセグメントをダブルクリックすると、譜面エディタウィンドウ中で1行の五線譜が開きます。

この方法で複数行の五線譜をオープンすることもできます。Shiftキーを押しながら、オープンしたい複数のセグメントの各々を、メイン表示上で選択(シングルマウスクリック)するか、最後のものをダブルクリックします。選択されたすべてのセグメントは1つの作譜ウィンドウ中に一緒にオープンされます。

既定のエディタメニュー機能でのオープン(リターンキー)

リターン(Enter)キーは既定のエディタメニュー機能の中のオープンのショートカットで、それはダブルクリックと同じです。譜面エディタ中で現在選択されているセグメントすべてをまとめてオープンするか、既定値として構成したその他のエディタでオープンします。

譜面エディタメニュー機能内でのオープン

代わりに、メインウィンドウのメニュー機能内の譜面エディタをオープン(Open in Notation Editor)機能か、キャンバス内のセグメント上の右ボタンによるポップアップメニュー上でオープンすることもできます。希望のセグメントを選択(上記のようにシフトキー+クリックか、すべてのセグメントを選択(Select All Segments)によって)し、次に、譜面エディタ中でオープン(Open in Notation Editor)を選択します。

もしも1つ以上の五線(すなわちセグメント)を譜面エディタ内で表示したいのであれば、同時に1つだけ、そのうちの1つのみを”カレント”にできます。カレントの五線は、その上に挿入カーソルを持つことで識別することができ(Rulers and Cursorsルーラとカーソルを参照)、挿入カーソルを使った任意の編集が行える五線となります。最上部の五線は既定値ではカレントですが、その上でAltキーを押しながらクリックするか、移動→ローカルカーソル→上の五線に移動*(Move → Local Cursor → Cursor Up Staff (Alt+Up))と下の五線に移動(Cursor Down Staff (Alt+Down))を使う事によって異なった五線に移動できます。

リニアとページレイアウト

譜面エディタが五線を表示する通常の方法は、リニアレイアウトとして知られているものです。1つの五線がその他の一番上にあり、それぞれの五線は単独の、水平にスクロール可能な長い行になっています。エディタのいくつかの機能、たとえばルーラ)は、リニアレイアウト表示→レイアウトモード→リニアレイアウト(View → Layout Mode → Linear Layout) のみで有効です。

しかし、2つの違ったページベースのレイアウト内で五線を表示させることも可能です。それは継続(Continuous)ページと複数(Multiple)ページです。

表示→継続ページレイアウト→リニアレイアウト(View → Continuous Page Layout → Linear Layout)継続レイアウトでは、楽曲はウィンドウとして同じ幅の無限の高さのページとして編集されます。各々の五線は各行の終わりで区切られ、残りの五線を以下に持つ新しい行で始まります。

表示→レイアウトモード→複数ページレイアウト(View → Layout Mode → Multiple Page Layout))による複数ページレイアウト内では、楽曲は印刷されるときの状態のページに分割されます。それぞれのページのサイズは、実際に印刷される時にそれぞれの行にほぼ同じ量の楽曲がフィットするように計算されます(構成ダイアログ中で印刷の解像度のために指定されたポイントサイズに従って)。印刷バージョンは、印刷するときに、明確に紙の大きさとマージンに依存するので、まったく同じということはありえないですが、A4サイズを使うときにはそれはかなり近くなっています。

Rosegardenの複数ページレイアウトにおける譜面エディタ

ほとんどではあるが、但し全部ではないのですが、表示と編集機能はリニアレイアウトと同じようにページレイアウトモードで動きます。

ルーラとカーソル

Rosegarden譜面エディタウィンドウは、それぞれ固有のカーソルに関連づけられている2つのメモリ付きのルーラを持っています。ルーラはメインの五線キャンバスの上から下までtickマークで分割された水平stripであり、カーソルは、エディタ中の一番上の五線の最初の部分に、初期状態で存在する、色つきの垂直ラインです。更に主な2つのものに追加すると、chord nameルーラ、tempoルーラとraw noteルーラがあります。

ルーラはリニアレイアウトモードでのみ表示され、 いくつかのものは既定値では表示されないことに注意してください。

譜面エディタでの2つのカーソル

紫色のカーソルは挿入カーソルです。これは、挿入かペーストが起こるような動作のポイントを表示します。一番上ののルーラ上でドラッグかクリックをするか、(任意のイベントを避ける)空白の五線の一部上でクリックするかドラッグするか、Ctrlキーを押したままどこかでクリックすることで挿入カーソルを移動することができます。

一度に1つのイベントを、挿入カーソルを移動するために、左か右の矢印キーを使うことができます。もしもCtrlキーを、矢印キーを押すときに押していると、カーソルは一度に次の小節線まで移動します。もしもShiftキーを押していると、カーソルはそれらをパスするように、イベントの選択を行ないます。 青のカーソルは再生ポインタです。マトリクス表示とメインウィンドウ内の同様のカーソルと同じく、これは、現在の再生または録音位置を示し、トランスポートがローリングしている間は、音符をまたいで通過します。これは下の方のルーラで位置を変更できます。

The raw note ruler

rawノートルーラは、実際のパフォーマンスのデュレーションがページ上の表示されているデュレーションと異なる場合、quantized notationを編集する時にとても便利です。設定→ルーラ→Rawノートルーラの表示(Settings → Rulers → Show Raw Note Ruler)経由で有効にすると、これは、マトリクス中で音符が表示されるのと似たような方法で、各音符の上に小さなバーを描画します。この例題の画面では、どのように解釈され、クォンタイズされた音符が、このルーラ上でどのように表示されるかを示しています。スタッカートの音符が相当短い間、テヌートの音符は完全なパフォーマンスのデュレーションを持っていて、アクセントの音符はより高いベロシティ(より赤い色)をそれらの近傍のものよりも持っています。

Rawノートルーラは、トラック中の選択されたセグメント中の音符のみマークします。選択されたセグメントの色は、セグメントの開始から終了時間の間のrawノートルーラの背景中で使われます。

The raw note ruler, showing notation whose performance duration value differs from what appears on the staff

コード名ルーラ

コード名ルーラは楽曲の調性を調べ、どのコードであるかを表示しようとします。これは、情報提供の目的用であり、このルーラの内容を印刷したり編集することは出来ません。印刷可能なコードを実際に書くためには、rosegardenファイル中のテキスト要素中のChordsセクションを見てください。

テンポルーラ

The tempo ruler displays the global tempo, and provides a vehicle for entering, editing, and manipulating it. It works the same way as the tempo rulers in the main window and the matrix editor. See Tempo Rulers for more information.

ツールと選択機能

ほとんどのRosegarden譜面エディタのメニューとツールバー編集機能は”ツール”、”選択機能”と”ドラッグ操作”の3つの機能に分類されます。

ツール

基本的なツールは、ツールバーボタンから通常アクセスできる、選択ツールF2、削除ツールF4で、それらは音符、休符、テキストやその他を挿入します。

The insert, erase, text, and guitar chord tools

ツールを選択すると、代わりに少なくとも他のツールが選択されるまで、メイン音符キャンバス上でマウスボタンの既定の動作が変わります。たとえば、選択ツールを選択すると、選択が可能になり、(以下の)選択ベースの機能が使えるようになります。挿入ツールを選択すると(たとえば音符の1つ)、GUIの動作が切り替えられ、キャンバス上でクリックすることで音符を挿入できます。削除ツールを選択すると、それらの上でクリックすることで、イベントを削除できます。

ツールメニューを使うことで、現在のツールを変更することもできます。

選択操作上の機能

残りの大多数のメニュー機能は、使う前にキャンバス上で選択することを要求します。そのうちのいくつかは、(たとえば、削除(Cut)tCtrl+Xか、音符スタイル)は、選択されたイベント上で動作します。その他は(たとえば符幹の方向)、いくつかの音符を選択するまで実行しません。

キャンバス上のいくつかのイベントを選択するために、選択ツールで選択したいイベントを含む矩形領域を囲みます。選択されたイベントは、青にハイライトされます。もしも1つのイベント上でクリックすると、そのイベントのみが選択されます6]

もしも、Shiftキーを矩形領域からドラッグアウトする間押しているならば、そのコンテンツは置換の代わりに、存在する任意の選択範囲に追加されます。

小節全体を選択するためには、小節内のどこか空白の場所で、選択ツールとともにダブルクリックします。全ての五線を選択するためには、3回クリックします編集(Edit)メニューは挿入カーソルの位置上を元にした拡張領域を選択するための機能を提供し、Shiftと左又は右矢印キーを押すことによって、挿入カーソルの周りのイベントを選択できます。

一度に、1つの五線より多くイベントを選択することはできません。

After selecting some events, you can filter your selection further using Edit → Filter Selection (Ctrl+F). For more details, refer to the corresponding function in the matrix editor.

ドラッグ操作

あるものの周りでドラッグを行なうことで、ひとまとまりの編集を行うことができます。選択ツールに切り替え、音符のピッチを、その譜頭を、クリックし、上か下にドラッグすることによって変更でき、音符の時間とその他のイベントは、それらを左か右にドラッグすることによって変更できます(残りの時間シグネチャにドラッグできませんが、それ以外はすべてドラッグできます。もしも1つ以上のイベントを選択しているならば、一度にすべて選択したものがドラッグされます)。

ドラッグは通常ツールバー機能やメニューを使うよりも、より少ない確実な手段ですが、それはより簡単です。

移調

Transposing by interval

楽譜ビューメニュー中で、任意の間隔で音符を移調するのに使う事が出来る2つの機能があり、それは、移調すべき音程を半音単位で指定できる、調整→移調→半音単位で移調(Adjust → Transpose → Transpose by Semitones)という名前のものと、調整→移調→間隔で移調(Adjust → Transpose → Transpose by Interval)という、音符を移調するのに使う、きちんとしたダイアログを表示するものがあります。後者は、移調の前後のサンプル音符をダイアログが表示し、目で見て分かる形で表現します。間隔はダイアログ中に表示されている音符をドラッグするか、そのベースノートから分離された、オクターブ指定と、臨時記号で変更できます。

セグメント→間隔で移調(Segment(s) → Transpose by Interval)経由で、音符とトラック(あるいは既定値)のビュー中で、間隔で移調にアクセスすることが出来ます。

音符と休符の挿入

音符を挿入するために、ツールバー上の音符の特定のデュレーション上をクリックすることで、音符ツールの1つを選択し、音符を挿入したい位置の五線上でクリックします。

The duration, rests, and accidentals toolbars

シャープが付いたかフラットが付いた音符を挿入するために、ツールバー上の臨時記号の1つを選択することが出来ます。もしもどの臨時記号も選択されていない場合、音符はキーシグネチャに従って挿入されます。その代わりに、楽譜上の同じ高さの最後に使ったどんな臨時記号にも音符を追従するように、以前の臨時記号アイコンに従うよう、を選択することが出来ます。

もしも、異なったデュレーションで存在する音符と同じ時間に音符を追加したい場合、エディタは通常和音を作成する事を仮定し、それゆえに、存在するか新しい音符を分割し、1つまたはそれ以上の和音をタイで結びます。もしも、異なった2つのデュレーションを和音にしたいのであれば、タイで結ばれた音符の符頭を選択し、それを結合するために、 調整→音符→Collapse Equal-Pitch Notes(Adjust → Notes → Collapse Equal-Pitch Notes) (Ctrl+=)を使います。その代わりに、既定値の動作はRosegarden設定ダイアログ中で変更でき、全く分割しないようにも出来ます。

もしも、異なったデュレーションの存在しているる音符上に正確に音符を追加するならば(すなわち同じピッチ)、存在している音符のデュレーションは新しいものによって変更されます。

もしも存在する音符と同じような長さ休符を追加すると、音符は休符のデュレーションのために無音化されるか、短くされるか、まとめて削除されます。

PCキーボードによる音符と休符の入力

デュレーション

最初に、挿入したい音符(か休符)のデュレーション内を指し示すように、確実に音符ツールが選択されるようにしてください。以下の数字キーを使うことによって色々な音符のタイプを選択できます。

  • 5 – Breve
  • 1 – 全音符 (semibreve)
  • 2 – 二分音符 (minim)
  • 4 – 四分音符 (crotchet)
  • 8 – 八分音符 (quaver)
  • 6 – 一六分音符 (semiquaver)
  • 3 – 三二分音符 (demisemiquaver)
  • 0 – 六四分音符 (hemidemisemiquaver)

Gキーを押すことで、三連符バージョンの音符のデュレーションに切り替えることができます。もう一回押すと、通常のデュレーションに切り替わります。ウィンドウの下部のステータスバーは三連符デュレーションデュレーションが有効の時にそれを通知します。

ピッチ

音符ツールが選択されると、以下のピッチキーのどれかを押すことによって挿入カーソルで現在の位置に音符を挿入することができます。

  • A – ド (the tonic of the current key in the current clef)
  • S – レ
  • D – ミ
  • F – ファ
  • J – ソ
  • K – ラ
  • L – シ

.キーを押すと、付点付きと付点なしのデュレーションを切り替えることができます。

キーを押している間Shiftキーを押すと、半音高くなり(#が定義されていないミとシを除く)、ShiftCtrlキーを一緒に押すと半音低くなります(ファとドを除く)。

To enter notes an octave higher, use the corresponding keys on the next row up: Q, W, E, R, U, I, and O. Likewise to enter notes an octave lower, use Z, X, C, V, B, N and M.

一オクターブ高い音符を入力するためには、以下にあるキーを使います。QWERUIO。同様に、壱オクターブ低い音符を入力するには、ZXCVBNMを使います。

休符

音符の代わりに休符を挿入するためには、Pを使います。その代わりに、現在のツールを切り替えて休符ツールに、また、音符ツールに再度戻すために、TYを使うことができます。

和音

既定値の譜面エディタの動作は、音符の挿入後に挿入カーソルを次に進め、メロディ中でその後に別の音符を挿入できるようになります。これは、最後のものと同じ時間に、その後の挿入を行う、和音モードに切り替える、ツール→和音挿入モード(Tools → Chord Insert Mode (H))を使う事により、切り替えることができます。再度Hを押すことで、メロディ挿入動作に戻ります。

音符のデュレーションの変更

すでに入力した音符のデュレーションを変更するためにキーボードを使う事が出来ます。変更したい音符が選択されているようにして、次に、変更したい音符に対応するCtrlプラス数字キーを押します。Ctrlプラス.で、付点を追加したり削除したいする事も出来ます。これを繰り返し押すと、1つの付点、2つの付点、および付点なしを順番に切り替えていきます。

Ctrlと同じように、Altを押すこともでき、そうすると、そのパーフォームしたデュレーションを変更なしに、譜面エディタ中で表示されている音符のデュレーションを変更する事が出来ます。これは、譜面を整えるのにとても便利です。notation from performance dataも参照してください。

その他の注意点

全ての挿入コマンドは、ツールメニューのサブメニューで有効です。1つの音符を挿入するためにメニューを操作することは、ありそうもないですが、メニューはショートカットを表示しますので、どのキーがどの機能か忘れた場合に有効なリファレンスを提供します。

キーボードショートカットはQWERTYレイアウトキーボード用に現在デザインされています。その他のレイアウトにキーをリマップする方法はまだなく、設定メニュー上の設定→ショートカットの設定….(Settings → Configure Shortcuts….)オプションを使うことによって各々のキーの再定義を個別に行ないます。FIXME this is no longer available without kde

数字を押す間にCtrlキーを押すと、関連する付点音符ツールを選択します。

MIDIキーボードからの音符の入力

MIDIキーボード又はその他のMIDI制御デバイスを使うことで、-ステップ録音として知られている - 譜面エディタ中に音符を入力することができます。譜面エディタはキーボード上で演奏したピッチを使いますが、デュレーションは、エディタそれ自身のグリッド設定中で選択したものを使います。

MIDIキーボードから音符を入力するために、最初に既定値のMIDIデバイスに、きちんとキーボードを構成することが必要です。次に音符ツールがデュレーションを設定するように、選択します。次に、マトリクスエディタのツールバー上のステップ録音ボタンを押すか、ツール→ステップ録音を選択します。その時点からMIDIキーボード上で押された全ての音は、ウィンドウがクローズするか、別のウィンドウが有効になるか、再度ステップ録音がoffにされるまでその音符ウィンドウ中に現在の挿入時間で挿入されます。

異なったデュレーションの音符を挿入するために、ステップ録音実行中の間グリッド設定を変更することができますし、和音モードHに移行することも出来ます。

音部記号と調

Rosegardenがこれらを扱う方法について最初に知っていることは、時間に関連した変更(テンポとタイムシグネチャ)が音部記号と調から全体にわたって異なるように扱われるということである。音符と同じように録音と再生の操作を簡単化するために、Rosegardenはテンポかタイムシグネチャが変更したとき、全ての五線中についてそれを行うことを要求します。1つの五線譜が2/4で、もう1つが同時に6/8か、1つの五線譜がビート120で、他が90であるようなことはできません。これは時間にのみ適用されます。音部記号と調についてはこのような制限はありません。Tempo in Rosegardenも参照してください。

音部記号、キー、テンポまたはタイムシグネチャを譜面エディタ内で変更したい場合、変更したい場所に挿入カーソル位置づけ、セグメント→音部記号の変更…調の変更テンポの変更か、Time Signatureの変更(Segment → Add Clef Change…, Add Key Change…, Add Tempo Change…, or Add Time Signature Change….)のどれかを使います。そうするとダイアログボックスが開き、適用したい、特定の音部記号、調、テンポ、あるいはTime Signatureが、以下のように出来ます。

音部記号

Rosegarden's clef dialog

ダイアログでは音部記号を選択できますが、音部記号を挿入する場所の位置移行に、すでに存在している音符がある場合、どのように音部記号を適用したいかを選ぶことも出来ます。

現在のピッチをメンテナンス

音部記号の後に続く任意の音符は現在のパフォーマンスピッチを保持します。

例えば、テノール記号を、それ以前のト音記号セクションの真ん中に挿入すると、それらは引き続きト音記号のピッチを保持しているため、その後に続く音符が五線のオクターブ上に移動します。

適切なオクターブに移調

音部記号の後に続く任意の音符は、オクターブ内で、そのピッチを保持しますが、新しい音部記号に適合するために、異なったオクターブに移動し、それゆえ、新しいピッチで演奏されます。

例えば、テノール記号を、それ以前のト音記号セクションの真ん中に挿入すると、音部記号の後に続く音符は新しい音部記号に適合するために1つの線だけ移動しますが、それ以前よりもオクターブ低く演奏します。

キー

Rosegarden's key signature dialog

ダイアログでは、 キーシグネチャを選択することが出来ますが、どのようにキーシグネチャを適用したいかを指定することも出来ます。以下のどれかを指定する必要があります:

キーシグネチャ

実際のキーシグネチャをダイヤルアップするために使われます。ダイアログは楽曲の調整を調査しようとし、譜面のその位置で、どのキーも適用されていない場合、キーシグネチャを推測します。

キーの移調

セグメントの移調によって移調するか、正確に指定されたキーを使うかを選ぶ必要があります。

たとえば、もしも、変ロ長調(Bb)というキーを、変ロ長調(Bb)移調楽器のトランペットパート譜用に挿入しようとする場合、それは-2分移調することになり、Rosegardenが、入力された変ロ長調(Bb)のキーがBb(コンサートAb)として書かれなければならないか、ハ長調(C)(コンサートBb)のトランペットキー中で結果を得るために、セグメントに対して移調すべきかを、Rosegardenに伝えるために、このオプションを使います。

スコープ

このキーシグネチャを現在のセグメントのみに適用するか、すべてのセグメントに適用するか、すべてのトラックに適用するか、この時点で適用するかを選ぶ必要があります。

もしも、この時点ですべてのセグメントを変更するよう適用する事を選ぶと、以前のキー移調の選択は、指定されたキーをすべてのセグメントが受け取るかどうか、あるいはセグメント単位で、適切にキーが移調するかを決定することを選べます。これは、コンサートピッチ中ですべてのキーの考慮から自由にし、Rosegardenにどの移調のためにどのキーが使われるかを理解させることが出来るようになるという理由で、インストゥルメントの移調のための譜面を扱うのに便利な方法です。

キーチェンジに引き続く存在する音符

このキーチェンジ移行の存在する任意の音符が現在のピッチをメンテナンスするか、キー中で現在の臨時符号をメンテナンスするかのどちらかを選ぶか、Rosegardenが新しいキー中にそのパートを移調することを試みさせるかを選ぶ必要があります。

テキスト、歌詞とLilyPondディレクティブ

歌詞の編集

LiliPondディレクティブの使用

LilyPond directives are a special kind of text that you can use to export .ly files that take advantage of functionality not yet available directly through Rosegarden's own native interface.

Some of these are a bit fiddly with respect to how their placement in time affects their function. It is not always immediately apparent at a glance just where they are, or what notes or barlines they will affect, so I have made placement suggestions to help ease the process of getting them in the right spot.

これらのディレクティブは以下の通りです:

Segno

used to export a

Coda

used to export a

Alt1

Placed anywhere in a measure, designates that the measure(s) that follow this one should be exported as the first alternate ending (see file lilypond-alternative-endings.rg for example)

Alt2

Placed anywhere in a measure, designates that the measure(s) that follow this one should be exported as the second alternate ending (see file lilypond-alternative-endings.rg for example)

|| →

Placed anywhere in a measure, designates that the next calculated barline will be rendered as a double barline (see file lilypond-directives.rg for example)

|. →

Placed anywhere in a measure, designates that the next calculated barline will be rendered as a terminating barline (see file lilypond-directives.rg for example)

: →

Placed anywhere in a measure, designates that the next calculated barline will be rendered as a dashed barline (see file lilypond-directives.rg for example)

Gliss.

Placed by clicking directly on a notehead, draws a glissando between the target note and the note immediately following (see file lilypond-directives.rg for example)

Arp.

Placed by clicking directly on a chord, draws a wavy line arpeggio symbol immediately to the left of the affected chord (see file lilypond-directives.rg for example)

Tiny →

Placed anywhere, designates that notation immediately following this directive should be rendered at the “tiny” size (see file lilypond-directives.rg for example)

Small →

Placed anywhere, designates that notation immediately following this directive should be rendered at the “small” size (see file lilypond-directives.rg for example)

Norm. →

Placed anywhere, designates that notation immediately following this directive should be rendered at the normal size; usually used to cancel a Tiny → or Small →. (see file lilypond-directives.rg for example)

Guitar Chords

You can add guitar chord diagrams to a notation track (or edit previously added ones). You can do this by toggling the guitar chord button, and then clicking on a note or barline. This will open the guitar chord dialog. With it you can select which guitar chord diagram you want to add from a chord dictionary which comprises most of the common chord fingerings by specifying a chord's root and its extension. For convenience, the fingerings are sorted in three different categories : beginner, common, and all. These categories are actually based on the chord extension (A7 is a beginner chord, while A13 isn't), not on the fingering itself, so you can still see “advanced” chord fingerings listed, even in beginner mode.

Rosegarden's chord selector dialog

You may add your own fingerings if needed. To do this, click on the New button. This will pop up a chord editor, where you can “draw” which fingering you want to add, and specify its root, chord extension, and starting fret number.

Rosegarden's chord editor dialog

Note that while you can choose the extension from a list of predefined values, you can also type whatever value you want. However, in that case, the new fingering will only be available in the “all” list. You can only delete and edit your own chords. Those from the predefined dictionary cannot be changed. If you spot a mistake in one of them, please report it to the development team.

スラーとヘアピン

スラーとヘアピン(クレッシェンド/デクレッシェンド) dynamic markingsは、イベントとして音符や休符と同じように保存されます。これらを生成するために、カバーしたい範囲(一続きの音符かその他)を選択し、次に、フレーズ→スラーの追加1)フレーズ→クレッシェンドの追加(Phrase → Add Crescendo (<))かフレーズ→デクレッシェンドの追加(Phrase → Add Decrescendo (>))オプションを使います。

Placement of hairpins can be somewhat tricky, and this is especially so with haripins that run in line with dynamic markings. It is commonly the case that a hairpin that doesn't quite look right in Rosegarden's own notation editor will nevertheless come out just fine once exported to LilyPond. Rosegarden's slurs generally come out best when all the stems are running in the same direction, and occasionally need to be repositioned by hand to achieve better placement. Slurs also tend to fare slightly better once exported to LilyPond.

その他のイベントと同じように、スラー又はヘアピンを取り除くことができます。選択ツールF2を使って選択し、次にDeleteキーを押すか、F4で削除ツールを有効にして、それをクリックします。

音符の符幹とスラッシュ

任意の選択された音符(何らかの符幹をそれらが持っている場合)の符幹の方向を、音符メニュー上の3つの符幹方向オプションを使う事で設定することが出来ます。オプションは符幹を上にするにはCtrl+Page Up を、下にするには Ctrl+Page Down を、さもなければRosegaredenは選択されたものの符幹を反転します。

音符→マーク(Note → Marks)メニューはまた、例えば、短く繰り返した音符やドラムロールのようなものを表示する為に、音符の符幹をまたがって、スラッシュのようなannotate noteにマークを追加するためのオプションの選択肢も用意しています。これらは現在のやり方です。譜面を演奏するか、MIDIを生成する時、Rosegardenはそれらを勘定に入れません。

連桁

音符に対して連桁を行う事は、Rosegardenの譜面エディタ中でグループ操作と考えることが出来ます。連桁を行いたい音符を選択し、フレーズ→連桁(Phrase → Beam Group) (Ctrl+B)メニューオプションを使います。連桁を解除するには、フレーズ→連桁解除(Phrase → Unbeam) (Ctrl+U)を使います。

同じ時におきる1つ以上の連桁グループを作ることも可能です - 選択し、一度に分離されたグループに連桁を行います - しかし、Rosegardenは通常、どの音符が符幹を上にし、どれが同時に連桁化したグループに対して符幹を下にするかを適切に処理することは余り上手ではありませんので、それらを連桁化するように、グループ化されている中の音符を明示的に符幹の方向で設定しなければならないでしょう。

Rosegardenは、余り複雑でないものが提供された場合、楽曲の、気が利いた連桁を推測しようとすることが出来ます。これを有効にするには、連桁化を計算したい音符を選択し(例えば、譜面全体を選択するために三回クリックすることで)、フレーズ→自動連桁(Phrase → Auto-Beam)を使います。自動連桁は、たとえば、MIDIファイルをロードした時と、音符を入力した時に、自動的に処理され、何らかの自動的な連桁をエディタは行います。

注意

これは、編集(Edit)タブ上の設定→Rosegardenの設定…(Settings → Configure Rosegarden…)オプションダイアログか、挿入ツールの右クリックメニューで適切な設定を行う時に、挿入時の自動連桁を変更する事により無効化できます。

三連符とその他の連符

貼り付けタイプ

譜面の調整

Adjusting note and rest durations

Normalizing rests

Sometimes as a result of editing or quantization operations, a piece of notation can end up with incorrect rest durations for the current time signature. You can use Adjust → Rests → Normalize Rests (Ctrl+N) to fix these. This examines each sequence of consecutive rests found in the selection, and adjusts, splits and merges rests as necessary to ensure that the rests have theoretically correct durations and fall on the correct boundaries.

For example, a 4/4 bar containing a crotchet (quarter-note), then a minim (half-note) rest and a crotchet rest will be rearranged to place the crotchet rest first, as the minim rest should not cross the central beat boundary of the bar.

Splitting very long notes

The Adjust → Notes → Tie Notes at Barlines is intended to deal with notes that have excessively long durations, and therefore overflow barlines or are too long to be displayed as a single note. It takes any such notes and splits them into shorter, tied notes.

Splitting overlapping notes

Adjust → Notes → Split-and-Tie Overlapping Chords can be used to turn “counterpoint” notes into a series of split-and-tied notes and chords.

It can be applied to a selection that contains overlapping notes. It will split overlapping notes at the point where they overlap, and tie together the resulting split notes, ensuring that the music takes the form of a series of chords and/or single notes starting and ending in neat blocks, with some notes possibly tied.

Rescaling note durations

You can use Adjust → Rescale → Halve Durations (Ctrl+H) and Adjust → Rescale → Double Durations (Ctrl+Shift+H) to perform the most simple rescaling.

For more elaborate rescalings, use Adjust → Rescale → Stretch or Squash… with which you scale the total length of the selection.

Repositioning notation elements

You may occasionally wish to to nudge the positioning of some element of notation that Rosegarden's layout algorithm has not placed in an optimal location. Use Ctrl-click and drag or Alt right or left arrow to move slurs, hairpins, text events, and several other sorts of events. You may not reposition notes in this fashion.

Interpreting Performance Cues in Notation

Notation from performance data

Rosegardenは多用途のプログラムです。これは譜面エディタですが、第一次的にはシーケンサと音楽を演奏するためのプログラムです。さらに、演奏中、もちろん、時間と音符のデュレーションは印刷された楽譜上ほど明確ではありません。

これは、譜面エディタ中で意味のある音符を表示させるために大量の基本的な音符の時間とデュレーションをたびたび試みることをRosegardenが行なうことが望ましいことを意味します。これはquantizationの一種であるが、大量の、驚くべき、あてずっぽうでうまく行なうことを要求する種類のものです。Rosegardenは、平面のグリッドquantizerよりもわずかによい仕事を行なうためにデザインされたquantizerを含みます。

Applying quantization strictly for notation is rather unimaginatively referred to as “notation quantization”: it only applies to the notes you see and edit in notation, and doesn't affect the notes that play, or that you edit in other views such as the matrix. This quantization is automatically applied to music imported or recorded from MIDI, although not all of its possible capabilities are enabled by default.

There are two ways to see which notes have been quantized for notation. By default, each notation view contains a raw note ruler (in the group of rulers above the score) showing a rectangular block for each note. This block is positioned so as to represent the time and duration of the note as performed, but with the top and bottom edges of the rectangle extended or shortened to represent the time after notation quantization. If this is too much information for you, you can choose in Settings → Configure Rosegarden… and choose the NotationLayout dialog to show in a green colour all note heads in the score that have had their timings altered by notation quantization.

Rosegarden's notation quantize dialog

If the quantization Rosegarden has used is not suitable, either for the entire score or for a selection of notes, you can choose to use a different level of quantization or none at all. To apply a different quantization to some notes, select the notes and use theQ button and tick the box labelled Quantize for notation only on that dialog. The quantization level or type used by default can be changed in the configuration dialog as follows.

Configurable parameters for the heuristic notation quantizer

Parameters for quantization itself

Complexity

The “complexity” of a notation quantizer is its most fundamental parameter. A “complex” quantizer will be more prepared to accept that complex-looking music is in fact intended to be complex, whereas a “simple” quantizer is more likely to assume that complex-looking music results from an imprecise performance of simple music.

The default setting is intended to produce reasonable results for a fairly wide range of music.

Base grid unit

The base grid unit (set to a note duration value) specifies the absolute minimum unit of note that will be permitted to remain in the score after quantization. For example, if set to a semiquaver, all notes will be placed on boundaries of a multiple of a semiquaver, with durations also a multiple of a semiquaver.

The setting of the base grid unit is not quite as significant for a notation quantizer as it is for a plain grid quantizer, because all it does is impose an absolute limit on the level of precision permitted by the complexity parameter. Mostly, when you find a case in which increasing the grid unit produces better results, you've actually found a case in which the quantizer simply didn't do as good a job as it should have been able to with the smaller unit.

Tuplet level

The notation quantizer is capable of identifying tuplets (triplets and other time-squashed groups), within reasonable limits. This parameter controls how ambitious it will attempt to be when looking for tuplets, by setting a limit on how many notes per tuplet group it will attempt to identify. If it is set to “None”, the quantizer will not attempt to identify tuplets at all.

Parameters that control tidying up after quantization

Re-beam

Causes the notes to be re-beamed into groups appropriately after quantization. This is usually desirable.

Add articulations (staccato, tenuto, slurs)

Causes the quantizer to attempt to identify, based on the durations of individual and consecutive notes, which notes should be notated with staccato marks (for notes that fall significantly short of the following note, but not apparently short enough to merit a rest), tenuto (for notes that almost or just overlap the following note) and slurs (for series of notes that meet or overlap).

Tie notes at barlines etc

Causes any notes that are still found after quantization to overlap barlines or to have durations not exactly expressible with single note heads to be split into multiple notes appropriately, and tied. This has the same effect as applying Tie Notes at Barlines in the notation view.

This parameter is not set by default because it changes the number of note events, which is undesirable when using Rosegarden partly or principally as a MIDI sequencer.

Split-and-tie overlapping chords

Causes overlapping notes to be split and tied, so as to make strict chords with individual noteheads tied as necessary. This has the same effect as applying Split-and-Tie Overlapping Chords in the notation view.

This parameter is not set by default partly because it changes the number of note events, which is undesirable when using Rosegarden partly or principally as a MIDI sequencer.

オルナメントの演奏

Rosegardenは、そのトリガされたセグメント機構を使って、オルナメントの演奏をサポートしています。使いたいと思う、種々の、トリルやオルナメントのようなタイプを含むトリガされたセグメントを作成する事が出来、演奏したいと思う音符にそれらを関連づけられます。

新しいタイプのオルナメントを作成するためには、最初に演奏させたいオルナメントを”in longhand”で、音符に書き、次にそれを音符を選択し、音符→オルナメント→オルナメントの作成….(Note → Ornaments → Make Ornament….)を作成します。これは、クリップボードに音符をカットし、新しいトリガされたセグメントに貼り付け、このセグメントをトリガする同じデュレーションの単一の音符で置き換えます。

存在するオルナメントを音符が演奏するようにさせるためには、それを選択し、音符→オルナメント→オルナメントのトリガ….(Note → Ornaments → Trigger Ornament….)を使います。

Rosegarden's Trigger Ornament dialog

トリガされたオルナメント中で演奏される音符を編集するために、トリガがある音符上でダブルクリックをすることが出来ます。これは、使用しているすべてのオルナメントを変更し、ダブルクリックしたものそれだけではありません。

Rosegardenはトリガされた音符に一致するためにピッチ中でトリガされたセグメントを上や下にシフトすることが出来る間、異なるキーかスケールの位置を移調するのは十分な機能を持っていないことに注意してください。

オルナメントとその他のトリガセグメントの使用方法については、 トリガされたセグメントを参照してください。

音符のスタイル

Rosegardenは、たとえば、符頭の選択、符尾の数を、音符が埋まっているか埋まっていないかにかかわらず、描画された音符の色々なタイプの色々な描画方法を変更することができます。

標準のスタイル(クラシック、クロス、三角とMensual)が提供され、音符→音符のスタイル(Note → Note Style)を使う事により、選択した特定の音符のスタイルを変更できます。各音符はどのスタイルが選択されたかを憶えていて、この情報はコンポジション中に格納されます。また、設定メニューの設定→Rosegardenの設定…*(Configure Rosegarden…)オプションを使う事で、新しい音符に対する既定値のスタイルを変更する事も出来ます。

XMLファイル中に音符のスタイルを記述することによって固有の音符スタイルを作成することもできます。(Even the standard styles are defined this way: the only reason the editor knows that a Classical semiquaver has a tilted oval filled head, a stem, two flags, etc., is that the description in Classical.xml says so.) See Customising Rosegarden for more information.

音符のフォント

Rosegardenは、Lilypondプロジェクトによって開発された、Fetaフォントという、スケーラブルな音符フォントを提供しています。Fetaはほとんどすべての古典的な仕事のために適合している、とても高品質のフォントです。

Rosegardenは、数多くの、その他の音符フォントを標準のサポートとしています。それらは、TrueType(.ttf)またはPostScript Type-1(.pfb,.pfa)形式のフォントで提供されることを必要とし、Rosegardenがインストールされた場所にそれらをインストールするために、関連したアクセス許可を必要とします。サポートされている音符フォントをインストールするために、Rosegardenがインストールされた所のshareディレクトリに位置づけます(通常/opt/kde/share/apps/rosegardenのようなKDEデスクトップのインストールツリーになります)。これは、”fonts”と呼ばれるサブディレクトリになります。そこにフォントファイルをコピーし、Rosegardenを再起動します。もしも、そのフォントがサポートされているならば、それは、譜面エディタのフォントメニューに現われます。

完全にサポート、あるいは部分的にサポートされている物は以下のフォントです。 Blake HodgettsによるFughetta、Petrucciという“オリジナルの” Finaleフォント、Maestroという“新しい”Finaleフォント、Opusという Sibeliusのフォント、InkpenというSibelius jazzフォント、AdobeからのSonata、CubaseシーケンサからのSteinbergとXinfonia(上記のフォントのほとんどは、各社の登録商標です)。THE ROSEGARDEN TEAM MAKES NO REPRESENTATION AS TO THE LEGAL STATUS OF ANY USE OF THESE FONTS WITH ROSEGARDEN. It is your responsibility to ensure you are in compliance with the licence (if any) under which a font was provided to you, before attempting to use it. If you are not sure whether you have the right to use a font, don't: apart from anything else, the standard Feta font is better than most of these anyway.

It is also possible to provide new mapping files so as to use new fonts. For some fonts that have similar mappings or metrics to fonts in the above list, this may be as simple as editing the name of the font in the mapping file. See Customising Rosegarden for more information.



6] You can also double-click on a single event to open an editing dialog for that event, but that's got nothing to do with selections.

7] This is why the default lyric text for a segment is usually full of dots.

1) Phrase → Add Slur ())、フレーズ→フレージングスラーの追加(Phrase → Add Phrasing Slur (Ctrl)
 
 
doc/notation-ja.txt · Last modified: 2013/07/02 12:55 (external edit)
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki