Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
dev:eclipse [2018/01/03 17:51]
tedfelix [Get Dependencies]
dev:eclipse [2018/07/18 15:33] (current)
tedfelix [Include Files and Symbols]
Line 96: Line 96:
  
 ===== Set Up Rosegarden Source Under Eclipse ===== ===== Set Up Rosegarden Source Under Eclipse =====
-//Note: These instructions were developed using Eclipse 4.(Oxygen).//+//Note: These instructions were developed using Eclipse 4.(Photon).//
  
 Since we set up the directory structure in a way that Eclipse likes, getting Eclipse to find the source and work with it is easy.  Launch Eclipse. ​ It will first ask for the location of your workspace. ​ Give it the rosegarden-workspace directory that we created earlier. ​ Since this is a new workspace, you'll get the Eclipse welcome screen. ​ In the upper right is a button for the "​Workbench"​. ​ Click it. Since we set up the directory structure in a way that Eclipse likes, getting Eclipse to find the source and work with it is easy.  Launch Eclipse. ​ It will first ask for the location of your workspace. ​ Give it the rosegarden-workspace directory that we created earlier. ​ Since this is a new workspace, you'll get the Eclipse welcome screen. ​ In the upper right is a button for the "​Workbench"​. ​ Click it.
Line 118: Line 118:
 ===== Include Files and Symbols ===== ===== Include Files and Symbols =====
 To make sure Eclipse is aware of the various Qt include files, we need to tell Eclipse where the Qt includes are located. ​ Select the "​rosegarden-svn"​ project in the Project Explorer and go to File > Properties. ​ In the "type filter text" box, type "​paths"​ and hit enter. ​ This should get you quickly to Paths and Symbols. ​ Click on the "​Includes"​ tab and then the "GNU C++" language. ​ In the "​Include directories"​ box, add the following: To make sure Eclipse is aware of the various Qt include files, we need to tell Eclipse where the Qt includes are located. ​ Select the "​rosegarden-svn"​ project in the Project Explorer and go to File > Properties. ​ In the "type filter text" box, type "​paths"​ and hit enter. ​ This should get you quickly to Paths and Symbols. ​ Click on the "​Includes"​ tab and then the "GNU C++" language. ​ In the "​Include directories"​ box, add the following:
- 
-  /​usr/​include/​qt4 
-  /​usr/​include/​qt4/​QtCore 
-  /​usr/​include/​qt4/​QtGui 
-  /​usr/​include/​qt4/​QtXml 
- 
-Note: For Qt5, the paths are slightly different: 
  
   /​usr/​include/​x86_64-linux-gnu/​qt5   /​usr/​include/​x86_64-linux-gnu/​qt5
-  ​etc...+  ​/​usr/​include/​x86_64-linux-gnu/​qt5/​QtCore 
 +  /​usr/​include/​x86_64-linux-gnu/​qt5/​QtGui 
 +  /​usr/​include/​x86_64-linux-gnu/​qt5/​QtXml 
 +  /​usr/​include/​x86_64-linux-gnu/​qt5/​QtWidgets
  
 Next, click on the # Symbols tab.  Verify that "GNU C++" is still selected. ​ In the Symbol box, add the following symbols and values: Next, click on the # Symbols tab.  Verify that "GNU C++" is still selected. ​ In the Symbol box, add the following symbols and values:
Line 139: Line 135:
  
 It will take some time for Eclipse to rebuild the index. ​ The "C/C++ Indexer"​ indicator at the bottom of the window will let you know how far along the process is. It will take some time for Eclipse to rebuild the index. ​ The "C/C++ Indexer"​ indicator at the bottom of the window will let you know how far along the process is.
 +
 +//Note: Qt4 is deprecated, but for reference, the include directories were://
 +
 +  /​usr/​include/​qt4
 +  /​usr/​include/​qt4/​QtCore
 +  /​usr/​include/​qt4/​QtGui
 +  /​usr/​include/​qt4/​QtXml
 +
  
 ===== Configuring Tabs ===== ===== Configuring Tabs =====
Line 156: Line 160:
  
 ===== Auto-Save Before Build ===== ===== Auto-Save Before Build =====
-By default, Eclipse doesn'​t automatically save your files when you build. ​ If you would prefer that behavior, go to Window > Preferences > General > Workspace. ​ Set the "Save automatically before build" checkbox. ​ This avoids build errors if you forget to save a file that you've changed.+By default, Eclipse doesn'​t automatically save your files when you build. ​ If you would prefer that behavior, go to Window > Preferences > General > Workspace ​> Build.  Set the "Save automatically before build" checkbox. ​ This avoids build errors if you forget to save a file that you've changed.
  
 ===== Unlimited Console Buffer ===== ===== Unlimited Console Buffer =====
 
 
dev/eclipse.1514998284.txt.gz · Last modified: 2018/02/07 17:07 (external edit)
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki