マトリクスエディタ

目次

Rosegardenのマトリクスエディタは、クリヤで論理的な形式で音楽を表示し、編集することを可能にします。それぞれの音符はグリッド中のブロックとして表わされ、高さはピッチに関連します。 Rosegardenのマトリクスエディタ

それぞれのマトリクスエディタウィンドウは1つのセグメントを表示します。セグメントを編集するためには、メインキャンバス中で単に右クリックし、セグメント→マトリクスエディタを開く(Segments → Open in Matrix Editor)(M)を選択します。その代わりに、セグメントをダブルクリックすると、マトリクスエディタが既定値のエディタになるようにRosegardenを設定することも可能です。

The Grid and Quantize controls

The matrix view contains Grid and Quantize menus in its main toolbar.

The Grid menu controls the size of the visible grid in the background of the matrix view, as well as the time resolution used when entering and moving notes. After you set it to a particular time value, the normal note insertion and drag operations will then snap automatically to grid points spaced at that time width. You can override the snap-to-grid effect temporarily by holding down Shift during editing, or you can disable it by setting the Grid menu to None.

The Quantize menu works rather differently. Rather than controlling the behaviour of other editing tools, it actually performs an action. When you change the value in this menu, the selected notes – or the whole segment if nothing is selected – will immediately be quantized using a grid quantizer of the chosen resolution.

The Quantize menu also shows you continuously what resolution the current segment or selection is quantized to. For example, if you select a set of notes that start on consecutive quarter-note beats, the Quantize menu will update itself to show 1/4, as this is the coarsest resolution consistent with the existing quantization of the current selection.

音符の挿入

マトリクスビューに音符を挿入する一番簡単な方法は、マウスを使うことです。これを行なうために、ツールバー上で鉛筆ツールを選択し、マトリクスエディタ上にクリックしドラッグします。音符と、そこでクリックした点に関連するピッチが入力され、マウスボタンをリリースする前に、関連した距離に関連するデュレーションが設定されるでしょう。

You can also draw notes using the select tool , by clicking and dragging either with the middle mouse button, or with the left mouse button and Ctrl pressed.

既定値では、時間とデュレーションは、ツールバー又は表示メニュー上のグリッド設定に添った形で、特定の格子点に貼り付けられます。クリックとドラッグ中にShiftキーを押したままにすることでこの効果を抑止できます。

PCキーボードでの音符の入力

デュレーション

The durations of notes entered from the keyboard are controlled by the Grid setting on the View → Grid menu or toolbar. You can set this using the number keys:

キーボードからのデュレーション入力は、表示→グリッドメニュー(View → Grid menu)設定又はツールバーによって制御されます。

  • 5 – 小節全体
  • 1 – Beat
  • 2 – 二分音符 (minim)
  • 4 – 四分音符 (crotchet)
  • 8 – 八分音符 (quaver)
  • 6 – 一六分音符 (semiquaver)
  • 3 – 三二分音符 (demisemiquaver)
  • 0 – 六四分音符 (hemidemisemiquaver)

ピッチ

Once the correct duration is selected in the Grid menu, you can insert a note at the current position of the insert cursor by pressing one of the pitch keys:

グリッドメニュー中でいったん正確なデュレーションが選択されると、以下のピッチキーの1つを押すことによって、挿入カーソルが示す現在の位置に音符を挿入できます。

  • A – ド (the tonic of the current key in the current clef)
  • S – レ
  • D – ミ
  • F – ファ
  • J – ソ
  • K – ラ
  • L – シ

キーを押す時にShiftキーを押すと、音符が半音上がり(シャープが定義されていないミとシは除く)、Shift+Ctrlキーを一緒に押すと、半音下がります(ファとドを除く)。

1オクターブ上を入力する場合はQ, WERUIOを使います。同様に、1オクターブ下を入力する場合にはZXCVBNMを使います。

その他の注意すべき点

すべてのコマンドの挿入はツールメニューのサブメニュー上で有効です。たった1つの音符を挿入するためにメニューを辿っていくことはありそうもないですが、メニューはキーボードショートカットを表示しているので、どのキーがどの機能に 割り当てられているかを忘れた場合には、役に立つリファレンスとなるでしょう。

キーボードショートカットは、現在QWERTYレイアウトキーボード用にデザインされています。その他のレイアウトにキーをリマップする方法はまだなく、設定→ショートカットを設定….(Settings → Configure Shortcuts….)を明示的に使うことにより、各々のキーの再定義を個別に行ないます。FIXME confirm this is not available in QT4 Rosegarden SOM

MIDIキーボードからの音符の入力

MIDIキーボード又はその他のMIDI制御デバイスを使うことでマトリクスエディタ中に音符を入力することができます。マトリクスエディタはキーボード上で演奏したピッチを使いますが、デュレーションは、エディタそれ自身のグリッド設定中で選択したものを使います。”ステップ録音”しても知られています。

MIDIキーボードから音符を入力するために、最初に既定値のMIDIデバイスに、きちんとキーボードを構成することが必要です。次に表示メニューかツールバー中で、正しいグリッド設定を行い、それが音符のデュレーションを制御するようにします。次に、マトリクスエディタのツールバー上のステップ録音ボタンを押すか、ツール→ステップ録音を選択します。その時点からMIDIキーボード上で押された全ての音は、ウィンドウがクローズするか、別のウィンドウが有効になるか、再度ステップ録音がoffにされるまでそのウィンドウ中に現在の挿入時間で挿入されます。

異なったデュレーションの音符を挿入するために、ステップ録音実行中の間グリッド設定を変更することができます。

音符の選択

マトリクスエディタ中で音符を選択するために、 F2 選択ツールにスイッチし、次に、選択したい音符を含む四角の領域を囲みます。選択されたイベントは青でハイライトされます。もしもその代わりに1つのイベント上でクリックすると、そのイベントのみが選択されます。

もしも、Shiftキーを、音符をクリックするか、四角で囲む間押しているならば、新しく選択される代わりに、現在選択しているものに追加されます。

選択を解除したい場合には、マトリクスエディタの空白の場所でクリックするか、Escapeキーを押します。

マトリクスエディタの左端のピアノキーボードの配下のキー上でシフトしながらクリックすることによって与えられたピッチの音符をすべて選択することができます。ピッチの範囲を選択するために、シフトキーを押しながらドラッグすることもできます。この選択は、今まで選択したものに追加されるので、新しく選択したい場合には古いものを先に消します。

Filtering the selection

Edit → Filter Selection offers you the ability to filter a range of events in any of several categories out of your selection. You can use this to refine the selection, if you want some action to apply to only certain events in it.

The event filter dialog

All ranges may be either inclusive or exclusive.

An inclusive range will remove events on either side of it from the selection. You can use this, for example, to filter everything below middle C and above the A above middle C out of your selection.

An exclusive range will remove the events within the range itself, leaving everything on either side of it selected. Using the same search points as in the previous example, you would use an exclusive range to remove everything between middle C and the A above middle C from your selection, while leaving everything above and below that range selected.

Once your selection has been filtered, you can manipulate it by any conventional means.

音符の移動とコピー

移動ツールと共にクリックしてドラッグするか、選択の後、選択ツールと共にドラッグするかをマトリクスエディタで行なうことによって、時間とピッチの両方中で音符を移動することができます。

音符をコピーするためには、まず選択し、標準のコピーと貼り付け機能を使います。貼り付け後、張り付けられた音符は代わりに選択され、必要なところにどこにもドラッグすることができます。選択ツールを使ってそれらを選択して、音符をコピーしてもよく、Ctrlを押しながら保持して、選択した音符をクリックとドラッグして新しい場所に置きます。

 
 
doc/matrix-ja.txt · Last modified: 2013/07/02 12:55 (external edit)
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki